Back
Maintenance

Testing maintenance 01

Completed 22 Apr at 01:50pm BST.

Universe Selfcare Universe Bigbang Firstcom - UK SIP Firstcom - DE SIP Firstcom - DK SIP
Completed

Maintenance completed

Posted 22 Apr at 01:50pm BST.
Started

Testing of maintenance window

Posted 22 Apr at 01:46pm BST.